identity_firebase_github 0.3.0

Flutter Android iOS

Github SSO by Firebase for Identity package

0
likes
60 / 110
pub points
4 %
popularity

We analyzed this package on Sep 23, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 12 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:identity_firebase_github/identity_firebase_github.dart that imports:
  • package:identity_firebase_github/src/firebase_github_authenticator.dart that imports:
  • package:github_sign_in/github_sign_in.dart that imports:
  • package:github_sign_in/src/github_sign_in.dart that imports:
  • package:github_sign_in/src/github_sign_in_page.dart that imports:
  • package:flutter_webview_plugin/flutter_webview_plugin.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:identity_firebase_github/identity_firebase_github.dart that imports:
  • package:identity_firebase_github/src/firebase_github_authenticator.dart that imports:
  • package:github_sign_in/github_sign_in.dart that imports:
  • package:github_sign_in/src/github_sign_in.dart that imports:
  • package:github_sign_in/src/github_sign_in_page.dart that imports:
  • package:flutter_webview_plugin/flutter_webview_plugin.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:identity_firebase_github/identity_firebase_github.dart that imports:
  • package:identity_firebase_github/src/firebase_github_authenticator.dart that imports:
  • package:github_sign_in/github_sign_in.dart that imports:
  • package:github_sign_in/src/github_sign_in.dart that imports:
  • package:github_sign_in/src/github_sign_in_page.dart that imports:
  • package:flutter_webview_plugin/flutter_webview_plugin.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:identity_firebase_github/identity_firebase_github.dart that imports:
  • package:identity_firebase_github/src/firebase_github_authenticator.dart that imports:
  • package:github_sign_in/github_sign_in.dart that imports:
  • package:github_sign_in/src/github_sign_in.dart that imports:
  • package:github_sign_in/src/github_sign_in_page.dart that imports:
  • package:flutter_webview_plugin/flutter_webview_plugin.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_auth^0.15.30.15.5+30.18.0+1
flutterflutter0.0.00.0.0
github_sign_in^0.0.10.0.30.0.3
identity^0.3.00.3.60.3.6
identity_firebase^0.3.00.3.00.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
emitter-1.2.01.2.0
firebase-7.3.07.3.0
firebase_auth_platform_interface-1.1.82.0.1
firebase_auth_web-0.1.3+10.3.0+1
firebase_core-0.4.50.5.0
firebase_core_platform_interface-1.0.42.0.0
firebase_core_web-0.1.1+20.2.0
flutter_web_plugins-0.0.00.0.0
flutter_webview_plugin-0.3.110.3.11
http-0.12.20.12.2
http_parser-3.1.43.1.4
js-0.6.20.6.2
matcher-0.12.90.12.9
meta-1.1.81.2.3
path-1.7.01.7.0
pedantic-1.9.01.9.2
plugin_platform_interface-1.0.21.0.2
quiver-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.15.3` on firebase_auth does not support the latest published version `0.18.0+1`

pubspec.yaml:14:18

   ╷
14 │   firebase_auth: ^0.15.3
   │                  ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs