idb_shim 2.0.0-nullsafety.3
idb_shim: ^2.0.0-nullsafety.3 copied to clipboard

indexed_db dart base interface with implementation for native (browser), file (io) and in memory.

10
likes
110/ 130
pub points
92%
popularity

We analyzed this package on Oct 5, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 154 out of 196 API elements (78.6 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/logger/logger_database.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection>=1.15.0-nullsafety.5 <3.0.01.15.01.15.0
js>=0.6.3-nullsafety.3 <2.0.00.6.30.6.3
path>=1.8.0-nullsafety.3 <3.0.01.8.01.8.0
sembast>=3.0.0-nullsafety.2 <3.0.03.0.0-nullsafety.53.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
meta-1.7.01.7.0
synchronized-3.0.03.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=3.0.0-nullsafety.2 <3.0.0` on sembast does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions sembast to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.2, Dart 2.14.2.

10
likes
110
pub points
92%
popularity

Publisher

tekartik.com

indexed_db dart base interface with implementation for native (browser), file (io) and in memory.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

collection, js, path, sembast

More

Packages that depend on idb_shim