icu_parser 1.3.0 icon indicating copy to clipboard operation
icu_parser: ^1.3.0 copied to clipboard

An extraction of icu parser from the intl_translation package

2
likes
110/ 140
pub points
73%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 114 out of 204 API elements (55.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:icu_parser/icu_parser.dart that imports:
  • package:icu_parser/intl_message.dart that imports:
  • package:analyzer/src/dart/ast/constant_evaluator.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/task/api/model.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/parser.dart that imports:
  • package:analyzer/src/fasta/ast_builder.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/macro.dart that imports:
  • package:analyzer/src/summary2/kernel_compilation_service.dart that imports:
  • package:_fe_analyzer_shared/src/macros/compiler/request_channel.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: Prefer typing uninitialized variables and fields.

lib/intl_message.dart:102:9

    ╷
102 │     var both;
    │         ^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/intl_message.dart

INFO: 'identifier' is deprecated and shouldn't be used. Use name instead.

lib/intl_message.dart:141:43

    ╷
141 │         outerArgs.parameters.map((x) => x.identifier!.name).toList();
    │                                           ^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/intl_message.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^4.3.04.7.05.2.0
petitparser^4.4.04.4.05.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-47.0.050.0.0
async-2.10.02.10.0
collection-1.17.01.17.0
convert-3.1.13.1.1
crypto-3.0.23.0.2
file-6.1.46.1.4
glob-2.1.12.1.1
meta-1.8.01.8.0
package_config-2.1.02.1.0
path-1.8.21.8.2
pub_semver-2.1.32.1.3
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-1.0.21.0.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^4.3.0 on analyzer does not support the stable version 5.0.0.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint ^4.4.0 on petitparser does not support the stable version 5.0.0.

Try running dart pub upgrade --major-versions petitparser to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Dart 2.18.4.

2
likes
110
pub points
73%
popularity

Publisher

verified publisher iconandrey.kabylin.ru

An extraction of icu parser from the intl_translation package

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

analyzer, petitparser

More

Packages that depend on icu_parser