iamport_flutter: ^0.9.13 copied to clipboard
Plugin that allows Flutter to use Iamport payment and certification functions.
We analyzed this package on Feb 26, 2021, and awarded it 75 pub points (of a possible 110):
10/10 points: Provide a valid
5/5 points: Provide a valid
0/5 points: Provide a valid
`CHANGELOG.md` contains too many non-ASCII characters.
The site uses English as its primary language. The content of
CHANGELOG.md in your package should primarily contain characters used in English.
10/10 points: Package has an example
- Found example at:
0/10 points: 20% or more of the public API has dartdoc comments
- 4 out of 135 API elements (3.0 %) have documentation comments.
Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.
10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)
Found 6 issues. Showing the first 2:
Consider supporting multiple platforms:
Package does not support Flutter platform Web
package:iamport_flutter/Iamport_certification.dartthat declares support for platforms: Android, iOS
20/30 points: code has no errors, warnings, lints, or formatting issues
lib/Iamport_certification.dart is not formatted according to dartfmt
To format your files run:
dartfmt -w .
10/10 points: All of the package dependencies are supported in the latest version
To reproduce run
pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.
The constraint `^5.1.1` on url_launcher does not support the stable version `6.0.0`, that was published 3 days ago.
When url_launcher is 30 days old, this package will no longer be awarded points in this category.
dart pub upgrade --major-versions url_launcher to update the constraint.
10/10 points: Package supports latest stable Dart and Flutter SDKs