iamport_flutter 0.9.13
iamport_flutter: ^0.9.13 copied to clipboard

Flutter Android iOS

Plugin that allows Flutter to use Iamport payment and certification functions.

6
likes
75 / 110
pub points
80 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 135 API elements (3.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:iamport_flutter/Iamport_certification.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/Iamport_certification.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_webview_plugin^0.3.50.3.110.3.11
uni_links^0.4.00.4.00.4.0
url_launcher^5.1.15.7.106.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
flutter_web_plugins-0.0.00.0.0
meta-1.3.0-nullsafety.31.3.0
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
url_launcher_linux-0.0.1+42.0.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.92.0.1
url_launcher_web-0.1.5+32.0.0
url_launcher_windows-0.0.1+32.0.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.1.1` on url_launcher does not support the stable version `6.0.0`, that was published 3 days ago.

When url_launcher is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions url_launcher to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

6
likes
75
pub points
80%
popularity

Plugin that allows Flutter to use Iamport payment and certification functions.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

mymusese@gmail.com
jang@siot.do

License

MIT (LICENSE)

Dependencies

flutter, flutter_webview_plugin, uni_links, url_launcher

More

Packages that depend on iamport_flutter