hypertext 0.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

hypertext #

version 0.0.0 build status

Alternative HTTP protocol library for Dart. The main difference here is that the developer gets a lot more freedom than with the dart:io implementation.

HTTP/2 support will come in the future.

Much of this library will work cross-platform, save for the Server class, as it depends on the dart:io ServerSocket class.

Why? #

This package only exists for the case in which the current dart:io HTTP server API's are removed, say in Dart 2.0.0.

I doubt this will ever happen, but if it does, frameworks like Angel, won't suddenly explode.

Also, hypertext is really useful for, say, writing a proxy, because requests and responses can instantly be exported toHttp(). Writing reverse proxies with Dart for me has been cumbersome so far.

Missing Features #

  • Cookies
  • WebSockets (although that would likely be another package, which would connect to web_socket_channel)

The following are deliberately left out:

  • Sessions

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  hypertext: ^0.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:hypertext/hypertext.dart';
  
Version Uploaded Documentation Archive
0.0.0 Jan 11, 2017 Go to the documentation of hypertext 0.0.0 Download hypertext 0.0.0 archive
1.0.0-alpha Mar 10, 2017 Go to the documentation of hypertext 1.0.0-alpha Download hypertext 1.0.0-alpha archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0