huawei_contactshield 6.4.0+300 copy "huawei_contactshield: ^6.4.0+300" to clipboard
huawei_contactshield: ^6.4.0+300 copied to clipboard

discontinued
PlatformAndroid

To help confront the global pandemic of coronavirus disease 2019, Huawei provides Contact Shield for developers to develop epidemic prevention and control apps.

3
likes
140/ 160
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

11 out of 235 API elements (4.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: huawei_contactshield, huawei_contactshield.CalibrationConfidence, huawei_contactshield.CalibrationConfidence.CalibrationConfidence, huawei_contactshield.CalibrationConfidence.HIGH, huawei_contactshield.CalibrationConfidence.LOW.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:huawei_contactshield/huawei_contactshield.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:huawei_contactshield/huawei_contactshield.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:huawei_contactshield/huawei_contactshield.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:huawei_contactshield/huawei_contactshield.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:huawei_contactshield/huawei_contactshield.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/constants/calibration_confidence.dart:17:1

   ╷
17 │ part of huawei_contactshield;
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/constants/calibration_confidence.dart

INFO: The part-of directive uses a library name.

lib/src/constants/contactshield_status.dart:17:1

   ╷
17 │ part of huawei_contactshield;
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/constants/contactshield_status.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

3
likes
140
pub points
0%
popularity

Publisher

verified publisherdeveloper.huawei.com

To help confront the global pandemic of coronavirus disease 2019, Huawei provides Contact Shield for developers to develop epidemic prevention and control apps.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (license)

Dependencies

flutter

More

Packages that depend on huawei_contactshield