huawei_ads 13.4.55+301 icon indicating copy to clipboard operation
huawei_ads: ^13.4.55+301 copied to clipboard

PlatformAndroid

Huawei Ads Kit plugin for Flutter utilizes Huawei's vast user base and extensive data capabilities to deliver targeted, high quality ad content to users.

Huawei Ads Kit Flutter Plugin

pub.dev version


This plugin enables communication between Huawei Ads SDK and Flutter platform. Huawei Ads Kit Plugin for Flutter provides the following 2 services:

  • Publisher Service: Huawei Ads Publisher Service utilizes Huawei's vast user base and extensive data capabilities to deliver targeted, high quality ad content to users. With this service, your app will be able to generate revenues while bringing your users content which is relevant to them.
  • Identifier Service: Huawei Ads Kit provides the open advertising identifier (OAID) for advertisers to deliver personalized ads and attribute conversions.

Learn More

Installation #

Please see pub.dev and AppGallery Connect Configuration.

Documentation #

Questions or Issues #

If you have questions about how to use HMS samples, try the following options:

  • Stack Overflow is the best place for any programming questions. Be sure to tag your question with huawei-mobile-services.
  • Github is the official repository for these plugins, You can open an issue or submit your ideas.
  • Huawei Developer Forum HMS Core Module is great for general questions, or seeking recommendations and opinions.
  • Huawei Developer Docs is place to official documentation for all HMS Core Kits, you can find detailed documentations in there.

If you run into a bug in our samples, please submit an issue to the GitHub repository.

License #

Huawei Ads Kit Flutter Plugin is licensed under Apache 2.0 license

17
likes
140
pub points
75%
popularity

Publisher

verified publisher icondeveloper.huawei.com

Huawei Ads Kit plugin for Flutter utilizes Huawei's vast user base and extensive data capabilities to deliver targeted, high quality ad content to users.

Homepage
Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on huawei_ads