http_extensions_retry 1.0.0
http_extensions_retry: ^1.0.0 copied to clipboard

An http extension that retries failed requests.

0
likes
110 / 130
pub points
54 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 14 API elements (28.6 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The operand can't be null, so the condition is always true.

lib/src/options.dart:29:24

   ╷
29 │       : assert(retries != null),
   │                        ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/options.dart

INFO: The operand can't be null, so the condition is always true.

lib/src/options.dart:30:30

   ╷
30 │         assert(retryInterval != null),
   │                              ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/options.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.13.00.13.10.13.1
http_extensions^1.0.01.0.01.0.0
logging^1.0.01.0.11.0.1
meta^1.3.01.3.01.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
http_parser-4.0.04.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Dart 2.12.2.