http_status 1.0.1+1

http_status #

Http Status Codes for dart.

codecov Codeship Status for era_productions/http_status

Usage #

A simple usage example:

import 'package:http_status/http_status.dart';

main() {

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

1.0.1+1 #

  • Moved coverage to dev_dependencies and downgraded to ^0.7.3

1.0.1 #

  • Added HttpStatus.fromCode constructor

1.0.0+3 #

  • Increased coverage

1.0.0+2 #

  • setup

1.0.0+1 #

  • Added dart_codecov_generator

1.0.0 #

  • Created HttpStatusCode and HttpStatus

0.0.1 #

  • Initial version, created by Stagehand


// Copyright (c) 2017, Era Productions. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:http_status/http_status.dart';

main() {

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  http_status: ^1.0.1+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:http_status/http_status.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0