hottie 0.0.1-dev.2
hottie: ^0.0.1-dev.2 copied to clipboard

Flutter Android iOS macOS

Experiment to run tests inside a running app, for faster feedback loop.

0
likes
100 / 110
pub points
0 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 8 API elements (25.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:hottie/hottie.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_testflutter0.0.00.0.0
test_api^0.2.00.2.19-nullsafety.20.2.19
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.0-nullsafety.12.5.0
boolean_selector-2.1.0-nullsafety.12.1.0
characters-1.1.0-nullsafety.31.1.0
charcode-1.2.0-nullsafety.11.2.0
clock-1.1.0-nullsafety.11.1.0
collection-1.15.0-nullsafety.31.15.0
fake_async-1.2.0-nullsafety.11.2.0
matcher-0.12.10-nullsafety.10.12.10
meta-1.3.0-nullsafety.31.3.0
path-1.8.0-nullsafety.11.8.0
sky_engine-0.0.990.0.99
source_span-1.8.0-nullsafety.21.8.1
stack_trace-1.10.0-nullsafety.11.10.0
stream_channel-2.1.0-nullsafety.12.1.0
string_scanner-1.1.0-nullsafety.11.1.0
term_glyph-1.2.0-nullsafety.11.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

0
likes
100
pub points
0%
popularity

Experiment to run tests inside a running app, for faster feedback loop.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

qwertyszot@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, flutter_test, test_api

More

Packages that depend on hottie