holiday_event_api 1.0.2 copy "holiday_event_api: ^1.0.2" to clipboard
holiday_event_api: ^1.0.2 copied to clipboard

The Official Holiday and Event API built for Dart and Flutter.

1
likes
140/ 140
pub points
43%
popularity

We analyzed this package 7 days ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/westy92/holiday-event-api-dart/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

102 out of 117 API elements (87.2 %) have documentation comments.

Some symbols that are missing documentation: holiday_event_api.AlternateName.AlternateName.fromJson, holiday_event_api.EventInfo.EventInfo.fromJson, holiday_event_api.EventInfo.url, holiday_event_api.EventSummary.EventSummary.fromJson, holiday_event_api.EventSummary.url.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:holiday_event_api/holiday_event_api.dart that imports:
  • package:holiday_event_api/src/holiday_event_api.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.0 2.0.5 2.0.5
http ^1.0.0 1.2.1 1.2.1
json_annotation ^4.8.1 4.8.1 4.8.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

1
likes
140
pub points
43%
popularity

Publisher

verified publisherwesty92.com

The Official Holiday and Event API built for Dart and Flutter.

Repository (GitHub)
View/report issues

Topics

#api #apis #client #event #http

Documentation

API reference

Funding

Consider supporting this project:

github.com

License

MIT (LICENSE)

Dependencies

equatable, http, json_annotation

More

Packages that depend on holiday_event_api