hive_api 0.4.6 copy "hive_api: ^0.4.6" to clipboard
hive_api: ^0.4.6 copied to clipboard

A simple API for connecting to the Hive network.

1
likes
110/ 160
pub points
0%
popularity

We analyzed this package 18 hours ago, and awarded it 110 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

50 out of 505 API elements (9.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: bridge_api, bridge_api.Account, bridge_api.Account.Account, bridge_api.Account.active, bridge_api.Account.balance.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The declaration '_$DiscussionFromJson' isn't referenced.

lib/src/models/discussion.g.dart:9:12

  ╷
9 │ Discussion _$DiscussionFromJson(Map<String, dynamic> json) => Discussion(
  │            ^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/models/discussion.g.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.3 2.0.5 2.0.5
http ^0.13.3 0.13.6 1.2.1
json_annotation ^4.5.0 4.9.0 4.9.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.19.0 1.19.0
http_parser - 4.1.0 4.1.0
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

1
likes
110
pub points
0%
popularity

Publisher

verified publisherleofinance.io

A simple API for connecting to the Hive network.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

equatable, http, json_annotation

More

Packages that depend on hive_api