hive2moor 1.0.5
hive2moor: ^1.0.5 copied to clipboard

Convert Hive files to Moor table definations.

2
likes
50 / 130
pub points
0 %
popularity

We analyzed this package on May 7, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 17 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:hive2moor/hive2moor.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Unused import: 'package:hive2moor/hive2moor.dart'.

bin/hive2moor.dart:1:8

  ╷
1 │ import 'package:hive2moor/hive2moor.dart' as hive2moor;
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/hive2moor.dart

INFO: The value of the local variable 'moorClassName' isn't used.

lib/src/Hive2MoorGenerator.dart:118:9

    ╷
118 │     var moorClassName = filename.substring(0, filename.length - 1);
    │         ^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/Hive2MoorGenerator.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.140.39.171.5.0
build^1.3.01.6.22.0.1
path^1.7.01.8.01.8.0
source_gen^0.9.7+10.9.10+21.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.021.0.0
args-1.6.02.1.0
async-2.6.12.6.1
charcode-1.2.01.2.0
cli_util-0.2.00.3.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
dart_style-1.3.62.0.1
file-5.2.16.1.0
glob-1.2.02.0.1
html-0.14.0+40.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
logging-1.0.11.0.1
meta-1.3.01.3.0
node_interop-1.2.12.0.1
node_io-1.2.02.0.0
package_config-1.9.32.0.0
pub_semver-1.4.42.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.39.14` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.3.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.1 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

2
likes
50
pub points
0%
popularity

Convert Hive files to Moor table definations.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ayaan.180410107098@gmail.com

License

Unlicense (LICENSE)

Dependencies

analyzer, build, path, source_gen

More

Packages that depend on hive2moor