hermes 3.0.0

Dart native js
Flutter Android iOS web

Messaging library for Dart. Nimble and efficient like the messenger of the Gods.

0
likes
105 / 110
pub points
27 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 105 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:59:49

   ╷
59 │ <p>Please file feature requests and bugs at the <a href="http://www.github.com/xenoken/hermes/issues">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/hermes_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 7 API elements (71.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
105
pub points
27%
popularity

Messaging library for Dart. Nimble and efficient like the messenger of the Gods.

Repository

Documentation

API reference

Uploader

ekeohak@gmail.com

License

BSD (LICENSE.md)

More

Packages that depend on hermes