hello_dart 0.3.3 copy "hello_dart: ^0.3.3" to clipboard
hello_dart: ^0.3.3 copied to clipboard

A visual and playful introduction to programming with the Dart language.

2
likes
25/ 160
pub points
0%
popularity

We analyzed this package 31 hours ago, and awarded it 25 pub points (of a possible 160):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 5 links are insecure.

README.md:8:1

  ╷
8 │ <a href="http://code.makery.ch/library/hello-dart/">Course Materials</a></p>
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
The lower bound of "sdk: '>=2.0.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.4. Cannot run `dart pub outdated`.

pubspec.yaml:7:8

  ╷
7 │   sdk: '>=2.0.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.4.

pubspec.yaml:7:8

  ╷
7 │   sdk: '>=2.0.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

0/20 points: Compatible with dependency constraint lower bounds

dart pub downgrade failed with:

OUT:
Resolving dependencies...
ERR:
The lower bound of "sdk: '>=2.0.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.

The current Dart SDK (3.4.4) only supports null safety.

For details, see https://dart.dev/null-safety

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

2
likes
25
pub points
0%
popularity

Publisher

verified publisherjakobservices.ch

A visual and playful introduction to programming with the Dart language.

Homepage

Documentation

Documentation

License

MIT (license)

Dependencies

collection, stagexl, string_scanner

More

Packages that depend on hello_dart