hbsegmented_control 0.0.1
hbsegmented_control: ^0.0.1

Flutter Android iOS web

我的第一个pub包

0
likes
70 / 110
pub points
27 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://juejin.im/user/5d67d9636fb9a06b2b478cad/activities was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 24 API elements (8.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/hbsegmented_control.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
27%
popularity

我的第一个pub包

Homepage

Documentation

API reference

Uploader

412625278@qq.com

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on hbsegmented_control