haystack_client 0.1.0-dev.0.5
haystack_client: ^0.1.0-dev.0.5

Dart native
Flutter Android iOS

Client for SkySpark servers using haystack protocol. SkySpark is a project to serve your IoT data and make analytics. Haystack defines a tagging model and REST API for IoT.

0
likes
80 / 110
pub points
23 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://bitbucket.org/kelegorm/haystack_flutter was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 36 out of 48 API elements (75.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:haystack_client/haystack_client.dart that imports:
  • package:haystack_client/src/client/h_skyspark_client.dart that imports:
  • package:haystack_client/src/auth/auth.dart that imports:
  • package:haystack/haystack.dart that imports:
  • package:haystack/src/client/SkysparkProj.dart that imports:
  • package:haystack/src/HProj.dart that imports:
  • package:haystack/src/UnknownRecError.dart that imports:
  • package:haystack/src/HRef.dart that imports:
  • package:haystack/src/string_utils.dart that imports:
  • package:unicode/unicode.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

lib/haystack_client.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/auth/auth.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.0.32.1.52.1.5
haystack^1.0.0-dev.0.2+41.0.0-dev.0.41.0.0-dev.0.4
http^0.12.00.12.20.12.2
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
http_parser-3.1.43.1.4
intl-0.16.10.16.1
lists-0.0.230.1.6
matcher-0.12.90.12.9
meta-1.2.41.2.4
path-1.7.01.7.0
pedantic-1.9.21.9.2
quiver-2.1.52.1.5
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
unicode-0.1.00.2.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
23%
popularity

Client for SkySpark servers using haystack protocol. SkySpark is a project to serve your IoT data and make analytics. Haystack defines a tagging model and REST API for IoT.

Homepage

Documentation

API reference

Uploader

dmitry@basservices.net

License

unknown (LICENSE)

Dependencies

crypto, haystack, http

More

Packages that depend on haystack_client