gsheet_to_arb 0.1.11
gsheet_to_arb: ^0.1.11 copied to clipboard

Imports Application Resource Bundle (ARB) from Google Sheets documents

12
likes
70 / 110
pub points
53 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 116 API elements (5.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:gsheet_to_arb/gsheet_to_arb.dart that imports:
  • package:gsheet_to_arb/src/config/plugin_config_manager.dart that imports:
  • package:gsheet_to_arb/src/utils/yaml_utils.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/src/config/plugin_config.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/config/plugin_config_manager.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args>=1.5.2 <2.0.01.6.02.0.0
code_builder>=3.1.3 <3.3.03.2.13.7.0
dart_style>=1.3.3 <2.0.01.3.62.0.0
file_utils>=0.1.1 <0.2.00.1.41.0.0
googleapis^0.54.00.54.02.0.0
googleapis_auth^0.2.60.2.12+11.1.0
intl>=0.16.1 <0.17.00.16.10.17.0
intl_translation^0.17.100.17.10+10.17.10+1
json_annotation^3.0.13.1.14.0.1
logging^0.11.40.11.41.0.1
path>=1.6.4 <2.0.01.8.01.8.0
petitparser^3.0.03.1.04.1.0
quiver^2.1.32.1.53.0.1
recase^3.0.03.0.13.0.1
yaml>=2.2.0 <2.3.02.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_discoveryapis_commons-0.1.91.0.0
_fe_analyzer_shared-7.0.020.0.0
async-2.5.02.5.0
built_collection-4.3.25.0.0
built_value-7.1.08.0.4
charcode-1.2.01.2.0
cli_util-0.2.00.3.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
file-5.2.16.1.0
fixnum-0.10.111.0.0
glob-1.2.02.0.1
globbing-0.3.11.0.0
html-0.14.0+40.15.0
http-0.12.20.13.1
http_parser-3.1.44.0.0
js-0.6.30.6.3
matcher-0.12.100.12.10
meta-1.3.01.3.0
node_interop-1.2.12.0.0
node_io-1.2.01.2.0
package_config-1.9.32.0.0
pub_semver-1.4.42.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 12 issues. Showing the first 2:

The constraint `>=1.5.2 <2.0.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `>=3.1.3 <3.3.0` on code_builder does not support the stable version `3.3.0`.

Try running dart pub upgrade --major-versions code_builder to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.