gs_flutter_widget 1.0.2
gs_flutter_widget: ^1.0.2 copied to clipboard

A Flutter Package to create reusable widget for list. Simple and easy to use.

3
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 102 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: The value of the local variable 'textShadow' isn't used.

lib/widgets/rounded_square_image_with_button_widget.dart:8:11

  ╷
8 │     final textShadow = Shadow(
  │           ^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/widgets/rounded_square_image_with_button_widget.dart

INFO: 'RaisedButton' is deprecated and shouldn't be used. Use ElevatedButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.25.0-8.1.pre..

lib/widgets/rounded_square_image_with_button_widget.dart:39:15

   ╷
39 │               RaisedButton(
   │               ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/widgets/rounded_square_image_with_button_widget.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

3
likes
90
pub points
0%
popularity

A Flutter Package to create reusable widget for list. Simple and easy to use.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

nicodemusdemuse@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on gs_flutter_widget