graphql_starwars_test_server_nils 0.0.2
graphql_starwars_test_server_nils: ^0.0.2 copied to clipboard

Dart native

A stand-alone GraphQL test server built with angel dart. Adapted from [example_star_wars](https://github.com/angel-dart/graphql/tree/master/example_star_wars)

0
likes
65 / 100
pub points
0 %
popularity

We analyzed this package on Mar 3, 2021, and awarded it 65 pub points (of a possible 100):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 10

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:graphql_starwars_test_server_nils/graphql_starwars_test_server_nils.dart that imports:
  • package:graphql_server/mirrors.dart that imports:
  • dart:mirrors
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/review_generator.dart:52:17

   ╷
52 │ final _random = new Random();
   │                 ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/review_generator.dart

INFO: Use `=` to separate a named parameter from its default value.

lib/src/models.dart:131:21

    ╷
131 │     bool isInterface: false,
    │                     ^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/models.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_container^1.1.01.1.01.1.0
angel_framework^2.0.12.1.12.1.1
angel_graphql^1.0.01.0.01.0.0
angel_http_exception^1.0.11.1.01.1.0
angel_model^1.0.01.0.31.0.3
angel_serialize^2.0.02.2.3+32.2.3+3
angel_typed_service^1.0.11.0.11.0.1
args^1.5.11.6.02.0.0
async^2.2.02.5.02.5.0
graphql_parser^1.1.41.1.41.1.4
graphql_schema^1.0.41.0.41.0.4
graphql_server^1.0.21.0.31.0.3
io^0.3.20.3.51.0.0
logging^0.11.30.11.41.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
angel_auth-2.1.5+12.1.5+1
angel_client-2.0.22.0.2
angel_file_service-2.0.12.0.1
angel_route-3.1.0+13.1.0+1
angel_validate-2.0.22.0.2
angel_websocket-2.0.32.0.3
charcode-1.2.01.2.0
clock-1.1.01.1.0
code_buffer-1.0.11.0.1
collection-1.15.01.15.0
combinator-1.1.01.1.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.16.1.0
http-0.12.20.13.0
http2-1.0.12.0.0
http_parser-3.1.44.0.0
http_server-0.9.8+30.9.8+3
intl-0.17.00.17.0
json_god-2.0.0-beta+32.0.0-beta+3
matcher-0.12.100.12.10
merge_map-1.0.21.0.2
meta-1.3.01.3.0
mime-0.9.71.0.0
mock_request-1.0.71.0.7
path-1.8.01.8.0
pedantic-1.10.01.10.0
pool-1.5.01.5.0
quiver-2.1.53.0.0
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-1.0.31.0.3
typed_data-1.3.01.3.0
uuid-2.2.23.0.1
web_socket_channel-1.2.02.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.5.1` on args does not support the stable version `2.0.0`, that was published 25 days ago.

When args is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.3.2` on io does not support the stable version `1.0.0`, that was published 5 days ago.

When io is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions io to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Dart 2.12.0.

0
likes
65
pub points
0%
popularity

A stand-alone GraphQL test server built with angel dart. Adapted from [example_star_wars](https://github.com/angel-dart/graphql/tree/master/example_star_wars)

Repository (GitHub)
View/report issues

Uploader

pierrenils.carlsson@gmail.com

License

MIT (LICENSE)

Dependencies

angel_container, angel_framework, angel_graphql, angel_http_exception, angel_model, angel_serialize, angel_typed_service, args, async, graphql_parser, graphql_schema, graphql_server, io, logging

More

Packages that depend on graphql_starwars_test_server_nils