graphql_flutter_bloc 1.0.0 copy "graphql_flutter_bloc: ^1.0.0" to clipboard
graphql_flutter_bloc: ^1.0.0 copied to clipboard

BLOC wrapper over `graphql_flutter` streams with improved state handling.

15
likes
100/ 140
pub points
75%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

36 out of 311 API elements (11.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: graphql_flutter_bloc, graphql_flutter_bloc.MutationBloc, graphql_flutter_bloc.MutationBloc.MutationBloc, graphql_flutter_bloc.MutationBloc.client, graphql_flutter_bloc.MutationBloc.completedTransformer.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 27 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/mutation/event.freezed.dart:183:17

    ╷
183 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/mutation/event.freezed.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/mutation/event.freezed.dart:442:17

    ╷
442 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/mutation/event.freezed.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bloc_concurrency ^0.2.2 0.2.4 0.2.4
flutter flutter 0.0.0 0.0.0
flutter_bloc ^8.1.3 8.1.4 8.1.4
freezed_annotation ^2.2.0 2.4.1 2.4.1
gql ^0.14.0 0.14.0 1.0.0+1
graphql ^5.1.3 5.1.3 5.1.3
http ^0.13.5 0.13.6 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
bloc - 8.1.3 8.1.3
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
gql_dedupe_link - 2.0.3+1 2.0.3+1
gql_error_link - 0.2.3+1 1.0.0+1
gql_exec - 0.4.3 1.0.0+1
gql_http_link - 0.4.5 1.0.1+1
gql_link - 0.5.1 1.0.0+1
gql_transform_link - 0.2.2+1 1.0.0
hive - 2.2.3 2.2.3
http_parser - 4.0.2 4.0.2
json_annotation - 4.8.1 4.8.1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
nested - 1.0.0 1.0.0
normalize - 0.7.2 0.9.1
path - 1.9.0 1.9.0
provider - 6.1.2 6.1.2
rxdart - 0.27.7 0.27.7
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.3.3
vector_math - 2.1.4 2.1.4
web_socket_channel - 2.2.0 2.4.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.0` on gql does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions gql to update the constraint.

The constraint `^0.13.5` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

15
likes
100
pub points
75%
popularity

Publisher

verified publisherartflutter.dev

BLOC wrapper over `graphql_flutter` streams with improved state handling.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bloc_concurrency, flutter, flutter_bloc, freezed_annotation, gql, graphql, http

More

Packages that depend on graphql_flutter_bloc