graph_display 0.1.1 copy "graph_display: ^0.1.1" to clipboard
graph_display: ^0.1.1 copied to clipboard

A package providing widgets for displaying graph structures in Flutter.

0
likes
130/ 140
pub points
33%
popularity

We analyzed this package 16 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: GPL-3.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

40 out of 71 API elements (56.3 %) have documentation comments.

Some symbols that are missing documentation: graph_display, graph_display.GraphThemePreferences.backgroundColour, graph_display.GraphThemePreferences.drawBackground, graph_display.GraphThemePreferences.drawEdge, graph_display.GraphThemePreferences.drawNode.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'background' is deprecated and shouldn't be used. Use surface instead. This feature was deprecated after v3.18.0-0.1.pre.

lib/src/graph_theme.dart:56:42

   ╷
56 │                       defaultColorScheme.background,
   │                                          ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/graph_theme.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.10.0 2.11.0 2.11.0
flutter flutter 0.0.0 0.0.0
graph_layout ^0.1.0 0.1.1 0.1.1
vector_math ^2.1.2 2.1.4 2.1.4
Transitive dependencies
Package Constraint Compatible Latest
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
quiver - 3.2.1 3.2.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

0
likes
130
pub points
33%
popularity
screenshot

Publisher

verified publisherarseny.uk

A package providing widgets for displaying graph structures in Flutter.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

GPL-3.0 (LICENSE)

Dependencies

async, flutter, graph_layout, vector_math

More

Packages that depend on graph_display