googleapis_beta 0.50.0

Dart native js
Flutter Android iOS web

Auto-generated client libraries for accessing Google APIs described through the API discovery service.

3
likes
90 / 110
pub points
68 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 11816 out of 17287 API elements (68.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5911 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/adexchangebuyer2/v2beta1.dart:29:39

   ╷
29 │   AccountsResourceApi get accounts => new AccountsResourceApi(_requester);
   │                                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/adexchangebuyer2/v2beta1.dart

INFO: Unnecessary new keyword.

lib/adexchangebuyer2/v2beta1.dart:30:37

   ╷
30 │   BiddersResourceApi get bidders => new BiddersResourceApi(_requester);
   │                                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/adexchangebuyer2/v2beta1.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
_discoveryapis_commons>=0.1.0 <0.3.00.2.00.2.0
http>=0.11.1 <0.13.00.12.20.12.2
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
http_parser-3.1.43.1.4
meta-1.2.31.2.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

3
likes
90
pub points
68%
popularity

Auto-generated client libraries for accessing Google APIs described through the API discovery service.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

kustermann@google.com
kevmoo@google.com
whesse@google.com
sigurdm@google.com
jonasfj@google.com

License

BSD (LICENSE)

Dependencies

_discoveryapis_commons, http

More

Packages that depend on googleapis_beta