google_secret_manager 1.1.0 copy "google_secret_manager: ^1.1.0" to clipboard
google_secret_manager: ^1.1.0 copied to clipboard

A library for accessing the Secret Manager API.

10
likes
120/ 140
pub points
55%
popularity

We analyzed this package 5 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

6 out of 6 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:google_secret_manager/google_secret_manager.dart that imports:
  • package:google_secret_manager/src/google_secret_manager_base.dart that imports:
  • package:googleapis_auth/auth_io.dart that imports:
  • package:googleapis_auth/src/oauth2_flows/authorization_code_grant_server_flow.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
googleapis ^11.2.0 11.4.0 13.1.0
googleapis_auth ^1.4.1 1.6.0 1.6.0
http ^1.0.0 1.2.1 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
_discoveryapis_commons - 1.0.6 1.0.6
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
google_identity_services_web - 0.3.1+1 0.3.1+1
http_parser - 4.0.2 4.0.2
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^11.2.0` on googleapis does not support the stable version `12.0.0`.

Try running dart pub upgrade --major-versions googleapis to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

10
likes
120
pub points
55%
popularity

Publisher

verified publishermiddelkamp.dev

A library for accessing the Secret Manager API.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

googleapis, googleapis_auth, http

More

Packages that depend on google_secret_manager