google_maps_util 0.0.3
google_maps_util: ^0.0.3 copied to clipboard

Helper Class Regarding PolyLine in google_maps_flutter

1
likes
60 / 110
pub points
71 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 4 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:google_maps_util/google_maps_util.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/poly_util.dart:10:29

   ╷
10 │     List<LatLng> path = new List<LatLng>();
   │                             ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/poly_util.dart

lib/google_maps_util.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
google_maps_flutter^0.5.190.5.332.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
flutter_plugin_android_lifecycle-1.0.112.0.1
google_maps_flutter_platform_interface-1.2.02.0.4
meta-1.3.01.3.0
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
stream_transform-1.2.02.0.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.19` on google_maps_flutter does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions google_maps_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

1
likes
60
pub points
71%
popularity

Helper Class Regarding PolyLine in google_maps_flutter

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

kjchuri95@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, google_maps_flutter

More

Packages that depend on google_maps_util