google_maps 6.1.0 icon indicating copy to clipboard operation
google_maps: ^6.1.0 copied to clipboard

Platformweb

With that package you will be able to use Google Maps JavaScript API from Dart scripts.

91
likes
100/ 130
pub points
95%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2631 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:google_maps/google_maps.dart that imports:
  • package:google_maps/src/generated/google_maps_core.js.g.dart that imports:
  • package:js_wrapping/js_wrapping.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
Package not compatible with platform iOS

Because:

  • package:google_maps/google_maps.dart that imports:
  • package:google_maps/src/generated/google_maps_core.js.g.dart that imports:
  • package:js_wrapping/js_wrapping.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
Package not compatible with platform Windows

Because:

  • package:google_maps/google_maps.dart that imports:
  • package:google_maps/src/generated/google_maps_core.js.g.dart that imports:
  • package:js_wrapping/js_wrapping.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
Package not compatible with platform Linux

Because:

  • package:google_maps/google_maps.dart that imports:
  • package:google_maps/src/generated/google_maps_core.js.g.dart that imports:
  • package:js_wrapping/js_wrapping.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
Package not compatible with platform macOS

Because:

  • package:google_maps/google_maps.dart that imports:
  • package:google_maps/src/generated/google_maps_core.js.g.dart that imports:
  • package:js_wrapping/js_wrapping.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 258 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/generated/core/event.dart:18:21

   ╷
18 │ external Object get _Event$namespace;
   │                     ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/generated/core/event.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/generated/core/street_view_panorama.dart:78:26

   ╷
78 │     PanoProviderOptions? opt_options,
   │                          ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/generated/core/street_view_panorama.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
js_wrapping^0.7.40.7.40.7.4
meta^1.3.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
js-0.6.40.6.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.12, Dart 2.17.0.

91
likes
100
pub points
95%
popularity

Publisher

unverified uploader

With that package you will be able to use Google Maps JavaScript API from Dart scripts.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

js_wrapping, meta

More

Packages that depend on google_maps