google_fonts 0.3.6
google_fonts: ^0.3.6 copied to clipboard

A package to include fonts from fonts.google.com in your flutter app.

2928
likes
90/ 130
pub points
100%
popularity

We analyzed this package on Nov 21, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1783 out of 1786 API elements (99.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:google_fonts/google_fonts.dart that imports:
  • package:google_fonts/src/google_fonts_base.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because mockito >=4.0.0 <=4.1.1 depends on test_api ^0.2.1 and mockito >=4.1.1+1 <4.1.2 depends on test_api >=0.2.1 <0.4.0, mockito >=4.0.0 <4.1.2 requires test_api >=0.2.1 <0.4.0.
And because mockito >=4.1.2 <=5.0.0-nullsafety.7 depends on test_api ^0.2.19-nullsafety and every version of flutter_test from sdk depends on test_api 0.4.2, flutter_test from sdk is incompatible[...]
So, because google_fonts depends on both flutter_test any from sdk and mockito ^4.1.1, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

2928
likes
90
pub points
100%
popularity

Publisher

material.io

A package to include fonts from fonts.google.com in your flutter app.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, http, path_provider

More

Packages that depend on google_fonts