go_router_builder 2.7.0 copy "go_router_builder: ^2.7.0" to clipboard
go_router_builder: ^2.7.0 copied to clipboard

A builder that supports generated strongly-typed route helpers for package:go_router

204
likes
110/ 140
pub points
95%
popularity

We analyzed this package 10 hours ago, and awarded it 110 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/flutter/flutter/issues?q=is%3Aissue+is%3Aopen+label%3A%22p%3A+go_router_builder%22 was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2 out of 2 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:go_router_builder/go_router_builder.dart that imports:
  • package:go_router_builder/src/go_router_generator.dart that imports:
  • package:go_router_builder/src/route_config.dart that imports:
  • package:go_router_builder/src/type_helpers.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:go_router_builder/go_router_builder.dart that imports:
  • package:go_router_builder/src/go_router_generator.dart that imports:
  • package:go_router_builder/src/route_config.dart that imports:
  • package:go_router_builder/src/type_helpers.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Windows

Because:

  • package:go_router_builder/go_router_builder.dart that imports:
  • package:go_router_builder/src/go_router_generator.dart that imports:
  • package:go_router_builder/src/route_config.dart that imports:
  • package:go_router_builder/src/type_helpers.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Linux

Because:

  • package:go_router_builder/go_router_builder.dart that imports:
  • package:go_router_builder/src/go_router_generator.dart that imports:
  • package:go_router_builder/src/route_config.dart that imports:
  • package:go_router_builder/src/type_helpers.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform macOS

Because:

  • package:go_router_builder/go_router_builder.dart that imports:
  • package:go_router_builder/src/go_router_generator.dart that imports:
  • package:go_router_builder/src/route_config.dart that imports:
  • package:go_router_builder/src/type_helpers.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:go_router_builder/go_router_builder.dart that imports:
  • package:go_router_builder/src/go_router_generator.dart that imports:
  • package:go_router_builder/src/route_config.dart that imports:
  • package:go_router_builder/src/type_helpers.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'withNullability' is deprecated and shouldn't be used. Only non-nullable by default mode is supported.

lib/src/go_router_generator.dart:82:55

   ╷
82 │         annotation.objectValue.type!.getDisplayString(withNullability: false);
   │                                                       ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/go_router_generator.dart

INFO: 'withNullability' is deprecated and shouldn't be used. Only non-nullable by default mode is supported.

lib/src/route_config.dart:600:47

    ╷
600 │             if (typeArgument.getDisplayString(withNullability: false) !=
    │                                               ^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/route_config.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer >=5.2.0 <7.0.0 6.5.0 6.5.0
async ^2.8.0 2.11.0 2.11.0
build ^2.0.0 2.4.1 2.4.1
build_config ^1.0.0 1.1.1 1.1.1
collection ^1.14.0 1.18.0 1.18.0
meta ^1.7.0 1.15.0 1.15.0
path ^1.8.0 1.9.0 1.9.0
source_gen ^1.0.0 1.5.0 1.5.0
source_helper ^1.3.0 1.3.4 1.3.4
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 68.0.0 68.0.0
_macros - 0.1.0 0.1.0
args - 2.5.0 2.5.0
checked_yaml - 2.0.3 2.0.3
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
macros - 0.1.0-main.0 0.1.0-main.5
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.