gmo_cli 1.0.0 copy "gmo_cli: ^1.0.0" to clipboard
gmo_cli: ^1.0.0 copied to clipboard

A sample command-line application.

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: gmo_cli,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: gmo_cli.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

27 out of 105 API elements (25.7 %) have documentation comments.

Some symbols that are missing documentation: args_mixin, args_mixin.ArgsMixin, cli_exception, cli_exception.CliException, cli_exception.CliException.CliException.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

WARNING: Unused import: 'dart:io'.

lib/core/internationalization.dart:1:8

  ╷
1 │ import 'dart:io';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/core/internationalization.dart

INFO: Unnecessary override.

lib/command/impl/help/help.dart:38:8

   ╷
38 │   bool validate() => super.validate();
   │        ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/command/impl/help/help.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ansicolor ^2.0.1 2.0.2 2.0.2
http ^0.13.4 0.13.6 1.2.1
path >=1.8.0 <2.0.0 1.9.0 1.9.0
process_run ^0.12.3+1 0.12.5+3 0.14.2
recase ^4.0.0 4.1.0 4.1.0
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
charcode - 1.3.1 1.3.1
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
meta - 1.14.0 1.14.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^0.12.3+1` on process_run does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions process_run to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

0
likes
90
pub points
0%
popularity

Publisher

unverified uploader

A sample command-line application.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ansicolor, http, path, process_run, recase

More

Packages that depend on gmo_cli