gmaps_by_road_distance_calculator 2.0.6 copy "gmaps_by_road_distance_calculator: ^2.0.6" to clipboard
gmaps_by_road_distance_calculator: ^2.0.6 copied to clipboard

This is a Package to calculate the by-road distance from one point to another in Gmap.

12
likes
130/ 160
pub points
70%
popularity

We analyzed this package 6 hours ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 11 API elements (9.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: gmaps_by_road_distance_calculator, gmaps_by_road_distance_calculator.ByRoadDistanceCalculator, gmaps_by_road_distance_calculator.ByRoadDistanceCalculator.ByRoadDistanceCalculator, gmaps_by_road_distance_calculator.ByRoadDistanceCalculator.distance, gmaps_by_road_distance_calculator.ByRoadDistanceCalculator.getDistance.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:gmaps_by_road_distance_calculator/gmaps_by_road_distance_calculator.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:gmaps_by_road_distance_calculator/gmaps_by_road_distance_calculator.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:gmaps_by_road_distance_calculator/gmaps_by_road_distance_calculator.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `iOS`.

Because:

  • package:gmaps_by_road_distance_calculator/gmaps_by_road_distance_calculator.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that imports:
  • package:google_maps_flutter_android/google_maps_flutter_android.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:gmaps_by_road_distance_calculator/gmaps_by_road_distance_calculator.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that imports:
  • package:google_maps_flutter_android/google_maps_flutter_android.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/gmaps_by_road_distance_calculator.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_polyline_points ^2.1.0 2.1.0 2.1.0
google_maps_flutter ^2.7.0 2.7.0 2.7.0
latlong2 ^0.9.1 0.9.1 0.9.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
csslib - 1.0.0 1.0.0
flutter_plugin_android_lifecycle - 2.0.20 2.0.20
flutter_web_plugins - 0.0.0 0.0.0
google_maps - 7.1.0 7.1.0
google_maps_flutter_android - 2.12.0 2.12.0
google_maps_flutter_ios - 2.10.0 2.10.0
google_maps_flutter_platform_interface - 2.8.0 2.8.0
google_maps_flutter_web - 0.5.8 0.5.8
html - 0.15.4 0.15.4
http - 1.2.2 1.2.2
http_parser - 4.0.2 4.1.0
intl - 0.19.0 0.19.0
js - 0.6.7 0.7.1
js_wrapping - 0.7.4 0.7.4
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sanitize_html - 2.1.0 2.1.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stream_transform - 2.1.0 2.1.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 1.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

12
likes
130
pub points
70%
popularity

Publisher

verified publisherabinvs.me

This is a Package to calculate the by-road distance from one point to another in Gmap.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

flutter, flutter_polyline_points, google_maps_flutter, latlong2

More

Packages that depend on gmaps_by_road_distance_calculator