gits_cucumber 3.2.1 copy "gits_cucumber: ^3.2.1" to clipboard
gits_cucumber: ^3.2.1 copied to clipboard

A gherkin / cucumber integration test runner flutter with gits_cli.

2
likes
140/ 160
pub points
26%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

146 out of 372 API elements (39.2 %) have documentation comments.

Some symbols that are missing documentation: gits_cucumber, gits_cucumber.ChildrenFeatureGherkinDocument, gits_cucumber.ChildrenFeatureGherkinDocument.ChildrenFeatureGherkinDocument, gits_cucumber.ChildrenFeatureGherkinDocument.background, gits_cucumber.ChildrenFeatureGherkinDocument.ChildrenFeatureGherkinDocument.fromJson.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:gits_cucumber/gits_cucumber.dart that imports:
  • package:gits_cucumber/src/support/support.dart that imports:
  • package:gits_cucumber/src/support/config.dart that imports:
  • package:patrol/patrol.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:gits_cucumber/gits_cucumber.dart that imports:
  • package:gits_cucumber/src/support/support.dart that imports:
  • package:gits_cucumber/src/support/config.dart that imports:
  • package:patrol/patrol.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:gits_cucumber/gits_cucumber.dart that imports:
  • package:gits_cucumber/src/support/support.dart that imports:
  • package:gits_cucumber/src/support/config.dart that imports:
  • package:patrol/patrol.dart that declares support for platforms: Android, iOS, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/support/reporter.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.18.0 1.19.0
equatable ^2.0.5 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
flutter_test flutter 0.0.0 0.0.0
integration_test flutter 0.0.0 0.0.0
patrol ^3.5.0 3.8.0 3.8.0
patrol_finders ^2.0.1+1 2.1.2 2.1.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
fake_async - 1.3.1 1.3.1
file - 7.0.0 7.0.0
flutter_driver - 0.0.0 0.0.0
fuchsia_remote_debug_protocol - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.1.0
json_annotation - 4.9.0 4.9.0
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
platform - 3.1.4 3.1.5
process - 5.0.2 5.0.2
shelf - 1.4.1 1.4.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
sync_http - 0.3.1 0.3.1
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.4
web - 0.5.1 0.5.1
webdriver - 3.0.3 3.0.3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
140
pub points
26%
popularity

Publisher

verified publishergits.id

A gherkin / cucumber integration test runner flutter with gits_cli.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

collection, equatable, flutter, flutter_test, integration_test, patrol, patrol_finders

More

Packages that depend on gits_cucumber