github_trending 0.2.0

Dart native js
Flutter Android iOS web

A library to get GitHub trending repositories and developers, with languages and period options.

1
likes
90 / 110
pub points
59 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/github_trending_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 67 API elements (3.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: The declaration '_$GithubTrendingRepositoryToJson' isn't referenced.

lib/src/model.g.dart:30:22

   ╷
30 │ Map<String, dynamic> _$GithubTrendingRepositoryToJson(
   │                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/model.g.dart

INFO: The declaration '_$GithubTrendingRepositoryBuiltByToJson' isn't referenced.

lib/src/model.g.dart:54:22

   ╷
54 │ Map<String, dynamic> _$GithubTrendingRepositoryBuiltByToJson(
   │                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/model.g.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.00.12.20.12.2
json_annotation^3.0.13.0.13.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
http_parser-3.1.43.1.4
meta-1.2.31.2.3
path-1.7.01.7.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
90
pub points
59%
popularity

A library to get GitHub trending repositories and developers, with languages and period options.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

pd4d10@gmail.com

License

MIT (LICENSE)

Dependencies

http, json_annotation

More

Packages that depend on github_trending