git2dart_binaries 0.3.0 copy "git2dart_binaries: ^0.3.0" to clipboard
git2dart_binaries: ^0.3.0 copied to clipboard

Dart bindings to libgit2, provides ability to use libgit2 library in Dart and Flutter.

0
likes
110/ 140
pub points
33%
popularity

We analyzed this package 9 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1700 out of 2794 API elements (60.8 %) have documentation comments.

Some symbols that are missing documentation: git2dart_binaries.BIG_ENDIAN, git2dart_binaries.BYTE_ORDER, git2dart_binaries.CLOCKS_PER_SEC, git2dart_binaries.CLOCK_BOOTTIME, git2dart_binaries.CLOCK_BOOTTIME_ALARM.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:git2dart_binaries/git2dart_binaries.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:git2dart_binaries/git2dart_binaries.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:git2dart_binaries/git2dart_binaries.dart that declares support for platforms: Windows, Linux, macOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 271 issues. Showing the first 2:

WARNING: The value of the field '__val' isn't used.

lib/src/bindings.dart:26487:31

      ╷
26487 │   external ffi.Array<ffi.Int> __val;
      │                               ^^^^^
      ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bindings.dart

WARNING: The value of the field '__locales' isn't used.

lib/src/bindings.dart:26545:50

      ╷
26545 │   external ffi.Array<ffi.Pointer<__locale_data>> __locales;
      │                                                  ^^^^^^^^^
      ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bindings.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.0.0 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
path ^1.8.1 1.9.0 1.9.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
pub_semver ^2.1.3 2.1.4 2.1.4
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

0
likes
110
pub points
33%
popularity

Publisher

verified publisherdartgit.dev

Dart bindings to libgit2, provides ability to use libgit2 library in Dart and Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffi, flutter, path, plugin_platform_interface, pub_semver

More

Packages that depend on git2dart_binaries