giphy_api_client 0.1.3 icon indicating copy to clipboard operation
giphy_api_client: ^0.1.3 copied to clipboard

A Giphy API Client for Dart compatible Web, Flutter, and server-side dart

0
likes
120/ 130
pub points
53%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 14 out of 235 API elements (6.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.13.40.13.50.13.5
meta^1.7.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
collection-1.16.01.16.0
http_parser-4.0.14.0.1
path-1.8.21.8.2
source_span-1.9.11.9.1
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.14, Dart 2.17.5.

0
likes
120
pub points
53%
popularity

Publisher

unverified uploader

A Giphy API Client for Dart compatible Web, Flutter, and server-side dart

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

http, meta

More

Packages that depend on giphy_api_client