gettext_parser 0.2.0 copy "gettext_parser: ^0.2.0" to clipboard
gettext_parser: ^0.2.0 copied to clipboard

Platform agnostic lib to parse and compile gettext po and mo files with dart

4
likes
140/ 160
pub points
91%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 3 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: gettext_parser, gettext_parser.mo, gettext_parser.po.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The file name 'sizeOfData.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run dart analyze lib/src/models/sizeOfData.dart

INFO: Use 'whereType' to select elements of a given type.

lib/src/po/compiler.dart:38:14

   ╷
38 │             .where((block) => block is Map)
   │              ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/po/compiler.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

4
likes
140
pub points
91%
popularity

Publisher

unverified uploader

Platform agnostic lib to parse and compile gettext po and mo files with dart

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

More

Packages that depend on gettext_parser