get_state 3.6.0
get_state: ^3.6.0 copied to clipboard

state management package based on dependency injection, use the MVVM pattern.(rename from ca_presentation)

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 44 API elements (43.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

ERROR: The instance member 'runtimeType' can't be accessed in an initializer.

lib/src/view.dart:18:15

   ╷
18 │             '$runtimeType<$VM>是一个View,它必须添加ViewModel泛型!'),
   │               ^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/view.dart

INFO: The value of the field '_bindVm' isn't used.

lib/src/model.dart:19:13

   ╷
19 │   ViewModel _bindVm;
   │             ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/model.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
get_arch_core>=0.6.1 <2.0.01.2.01.2.0
get_it^4.0.24.0.46.1.1
rxdart^0.24.10.24.10.26.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
characters-1.1.01.1.0
collection-1.15.01.15.0
dartz-0.9.20.9.2
equatable-1.2.62.0.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.2` on get_it does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions get_it to update the constraint.

The constraint `^0.24.1` on rxdart does not support the stable version `0.25.0`.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

0
likes
70
pub points
0%
popularity

state management package based on dependency injection, use the MVVM pattern.(rename from ca_presentation)

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

mr.huwt@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, get_arch_core, get_it, rxdart

More

Packages that depend on get_state