get_state 3.5.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 60

get_state #

state management package

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[3.5.1] - 2020/7/5 #

  • fix(ViewModel): Calling the "View.registerVM" multiple times will not repeat the registration; see: main4x1.dart

[3.5.0] - 2020/7/4 #

  • remove : freezed_annotation package
  • feat(ViewModel): ViewModel.vmUpdate()add"bool forceUpdate"param

[3.4.0] - 2020/6/24 #

  • feat: View level VM register, see: main4x1.dart
  • remove: VM async init.
  • feat: use freezed for Model, see: main5.dart

[3.3.0] - 2020/5/31 #

  • fix: vmUpdate logic bug
  • feat: View can init Model in onInitState() with vmInitModel() see: main7.dart
  • add: check mounted before setState()
  • add: new example "main7.dart"

[3.2.1] - 2020/5/25 #

  • feat: add onInitState() and onDispose() to ViewModel, To help you use some Controller

[3.2.0+1] - 2020/5/25 #

  • fix: v3.2.0 is dev version, don't use.

[3.2.0] - 2020/5/14 #

  • feat: add mixin"Recorder" for ViewModel, Allows toggling between historical states
  • refactor: rename "ViewModel.model" to "ViewModel.m"

[3.1.0] - 2020/5/3 #

  • feat: Asynchronous initialization ViewMode
  • add(main5.dart): Corresponding examples

[3.0.0] - 2020/5/3 #

  • rename from ca_presentation package
  • add: example

example/README.md

get_state_example #

A new Flutter application.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  get_state: ^3.5.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:get_state/get_state.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • get_state that is a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
get_it ^4.0.2 4.0.2
Transitive dependencies
async 2.4.2
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test