get_started 0.1.0
get_started: ^0.1.0 copied to clipboard

A Flutter Getting Started Walkthrough Layout package. Adds a Getting Started Guide/Tutorial to applications. Customize and use! :).

0
likes
50 / 100
pub points
0 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 50 pub points (of a possible 100):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 10

10/10 points: Package has an example

  • Found example at: example/lib/example.dart
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

ERROR: The name 'Page' is defined in the libraries 'package:flutter/src/widgets/navigator.dart' and 'package:get_started/classes/page.dart'.

lib/get_started.dart:13:3

   ╷
13 │   Page pg = new Page();
   │   ^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/get_started.dart

ERROR: The name 'Page' is defined in the libraries 'package:flutter/src/widgets/navigator.dart' and 'package:get_started/classes/page.dart'.

lib/get_started.dart:13:17

   ╷
13 │   Page pg = new Page();
   │                 ^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/get_started.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
page_indicator^0.2.00.2.10.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.2.0` on page_indicator does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions page_indicator to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Flutter 1.26.0-17.8.pre, Dart 2.12.0 (build 2.12.0-259.16.beta).

0
likes
50
pub points
0%
popularity

A Flutter Getting Started Walkthrough Layout package. Adds a Getting Started Guide/Tutorial to applications. Customize and use! :).

Homepage

Uploader

dharmikisback@gmail.com

License

BSD (LICENSE)

Dependencies

flutter, page_indicator

More

Packages that depend on get_started