get_server 1.2.1 icon indicating copy to clipboard operation
get_server: ^1.2.1 copied to clipboard

A backend server (http and websocket) that makes it possible to program with Flutter syntax and reuse existing code

295
likes
130/ 140
pub points
82%
popularity

We analyzed this package 9 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 450 out of 1292 API elements (34.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:get_server/get_server.dart that imports:
  • package:get_server/src/widgets/pageable.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Duplicate import.

lib/src/widgets/pageable.dart:5:8

  ╷
5 │ import '../../get_server.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/widgets/pageable.dart

lib/src/core/src/server_main.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
jaguar_jwt^3.0.03.0.03.0.0
meta>=1.3.0 <2.0.01.9.01.9.0
mime^1.0.01.0.41.0.4
path^1.8.01.8.31.8.3
Transitive dependencies
PackageConstraintCompatibleLatest
auth_header-3.0.13.0.1
collection-1.17.11.17.1
crypto-3.0.23.0.2
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.0.

295
likes
130
pub points
82%
popularity

Publisher

verified publisher icongetx.site

A backend server (http and websocket) that makes it possible to program with Flutter syntax and reuse existing code

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

jaguar_jwt, meta, mime, path

More

Packages that depend on get_server