get_env_info 0.6.2
get_env_info: ^0.6.2 copied to clipboard

GetArch infrastructure package, get app environment information

0
likes
50 / 110
pub points
0 %
popularity

We analyzed this package on Apr 12, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 67 API elements (7.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

ERROR: Missing concrete implementation of 'getter IGetArchPackage.interfaceImplRegisterStatus'.

lib/profile/env_info_package.dart:17:7

   ╷
17 │ class EnvInfoPackage extends IGetArchPackage {
   │       ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/profile/env_info_package.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/interface/dto/dto.g.dart:9:15

  ╷
9 │ _$_EnvInfoDto _$_$_EnvInfoDtoFromJson(Map<String, dynamic> json) {
  │               ^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/interface/dto/dto.g.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
device_info^0.4.2+40.4.2+102.0.0
flutterflutter0.0.00.0.0
freezed_annotation^0.11.00.11.0+10.14.1
get_arch_core>=0.6.1 <2.0.01.2.01.2.0
injectable^0.4.0+10.4.0+11.2.2
json_serializable^3.3.03.5.14.1.0
package_info^0.4.10.4.3+42.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.020.0.0
analyzer-0.41.21.4.0
args-2.0.02.0.0
async-2.5.02.5.0
build-1.6.22.0.0
build_config-0.4.70.4.7
characters-1.1.01.1.0
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
dart_style-1.3.122.0.0
dartz-0.9.20.9.2
device_info_platform_interface-1.0.12.0.1
equatable-1.2.62.0.0
file-6.1.06.1.0
get_it-4.0.46.1.0
glob-2.0.12.0.1
json_annotation-3.1.14.0.1
logging-1.0.11.0.1
meta-1.3.01.3.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
plugin_platform_interface-1.0.32.0.0
pub_semver-2.0.02.0.0
pubspec_parse-0.1.81.0.0
rxdart-0.24.10.26.0
sky_engine-0.0.990.0.99
source_gen-0.9.10+31.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^0.4.2+4` on device_info does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions device_info to update the constraint.

The constraint `^0.11.0` on freezed_annotation does not support the stable version `0.12.0`.

Try running dart pub upgrade --major-versions freezed_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.