get_arch_quick_start 1.0.0
get_arch_quick_start: ^1.0.0 copied to clipboard

GetArch quick start support

0
likes
40 / 110
pub points
0 %
popularity

We analyzed this package on Apr 11, 2021, and awarded it 40 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 90 out of 234 API elements (38.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:get_arch_quick_start/domain/value_validators.dart that imports:
  • package:get_arch_quick_start/quick_start.dart that imports:
  • package:get_arch_quick_start/profile/quick_start_package.dart that imports:
  • package:get_arch_quick_start/quick_start_part.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

ERROR: The name 'ActionFactory' isn't a type so it can't be used as a type argument.

lib/profile/get_arch_application_x.dart:78:19

   ╷
78 │     Map<LocalKey, ActionFactory> actions,
   │                   ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/profile/get_arch_application_x.dart

ERROR: The argument type 'Map

lib/profile/get_arch_application_x.dart:119:7

    ╷
119 │       actions: actions,
    │       ^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/profile/get_arch_application_x.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bot_toast>=3.0.0 <4.0.03.0.54.0.1
dio>=3.0.0 <4.0.03.0.104.0.0
flutterflutter0.0.00.0.0
flutter_gifimage>=1.0.0 <2.0.01.0.11.0.1
get_arch_core>=1.0.0 <2.0.01.2.01.2.0
hive>=1.4.1+1 <2.0.01.4.4+12.0.2
injectable>=1.0.0 <2.0.01.1.01.2.2
path_provider>=1.6.10 <2.0.01.6.282.0.1
pretty_dio_logger>=1.1.0 <2.0.01.1.11.1.1
pull_to_refresh>=1.6.0 <2.0.01.6.51.6.5
verify>=1.1.0 <2.0.01.1.11.1.4
web_socket_channel>=1.1.0 <2.0.01.2.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
dartz-0.9.20.9.2
equatable-1.2.62.0.0
ffi-1.0.01.0.0
file-6.1.06.1.0
get_it-4.0.46.0.0
http_parser-3.1.44.0.0
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
rxdart-0.24.10.26.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `>=3.0.0 <4.0.0` on bot_toast does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions bot_toast to update the constraint.

The constraint `>=3.0.0 <4.0.0` on dio does not support the stable version `4.0.0`, that was published 14 days ago.

When dio is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.