get_arch_quick_start 1.0.0
get_arch_quick_start: ^1.0.0 copied to clipboard

GetArch quick start support

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add get_arch_quick_start

With Flutter:

 $ flutter pub add get_arch_quick_start

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  get_arch_quick_start: ^1.0.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:get_arch_quick_start/domain/error/error.dart';
import 'package:get_arch_quick_start/domain/error/failures.dart';
import 'package:get_arch_quick_start/domain/value_validators.dart';
import 'package:get_arch_quick_start/infrastructure/network_impl.dart';
import 'package:get_arch_quick_start/infrastructure/storage_impl.dart';
import 'package:get_arch_quick_start/infrastructure/ui/dialog_impl.dart';
import 'package:get_arch_quick_start/infrastructure/ui/indicator.dart';
import 'package:get_arch_quick_start/infrastructure/ui/views.dart';
import 'package:get_arch_quick_start/interface/i_dialog.dart';
import 'package:get_arch_quick_start/interface/i_network.dart';
import 'package:get_arch_quick_start/interface/i_storage.dart';
import 'package:get_arch_quick_start/profile/get_arch_application_x.dart';
import 'package:get_arch_quick_start/profile/quick_start_package.config.dart';
import 'package:get_arch_quick_start/profile/quick_start_package.dart';
import 'package:get_arch_quick_start/quick_start.dart';
import 'package:get_arch_quick_start/quick_start_part.dart';