geopointer 0.0.2 copy "geopointer: ^0.0.2" to clipboard
geopointer: ^0.0.2 copied to clipboard

A lightweight flutter library for common latitude and longitude calculation..

1
likes
120/ 160
pub points
14%
popularity

We analyzed this package 45 hours ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

55 out of 141 API elements (39.0 %) have documentation comments.

Some symbols that are missing documentation: expect, expect.LazyMessage, expect.isTrue, expect.notNull, geopointer.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:geopointer/geopointer.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:geopointer/geopointer.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:geopointer/geopointer.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:geopointer/geopointer.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 48 issues. Showing the first 2:

WARNING: The keyword 'final' isn't necessary because the parameter is implicitly 'final'.

lib/geopointer/GCircle.dart:11:11

   ╷
11 │   GCircle(final GeoLatLng this.center, this.radius,
   │           ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/geopointer/GCircle.dart

WARNING: The operand can't be null, so the condition is always 'false'.

lib/geopointer/expect.dart:21:18

   ╷
21 │   if (expression == null || expression == false) {
   │                  ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/geopointer/expect.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
intl ^0.17.0 0.17.0 0.19.0
logging ^1.0.0 1.2.0 1.2.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

1
likes
120
pub points
14%
popularity

Publisher

unverified uploader

A lightweight flutter library for common latitude and longitude calculation..

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, intl, logging

More

Packages that depend on geopointer