geoflutterfire 3.0.3 copy "geoflutterfire: ^3.0.3" to clipboard
geoflutterfire: ^3.0.3 copied to clipboard

GeoFlutterFire is an open-source library that allows you to store and query firestore documents based on their geographic location.

388
likes
130/ 140
pub points
94%
popularity

We analyzed this package 11 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

14 out of 42 API elements (33.3 %) have documentation comments.

Some symbols that are missing documentation: geoflutterfire, geoflutterfire.Coordinates, geoflutterfire.Coordinates.Coordinates, geoflutterfire.Coordinates.latitude, geoflutterfire.Coordinates.longitude.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:geoflutterfire/geoflutterfire.dart that imports:
  • package:geoflutterfire/src/models/distance_doc_snapshot.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:geoflutterfire/geoflutterfire.dart that imports:
  • package:geoflutterfire/src/models/distance_doc_snapshot.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:geoflutterfire/geoflutterfire.dart that imports:
  • package:geoflutterfire/src/models/distance_doc_snapshot.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/test_text_input_key_handler.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cloud_firestore ^3.1.6 3.5.1 4.17.5
flutter flutter 0.0.0 0.0.0
flutter_lints ^1.0.0 1.0.4 4.0.0
rxdart ^0.27.3 0.27.7 0.27.7
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.0.2 1.3.35
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
cloud_firestore_platform_interface - 5.7.7 6.2.5
cloud_firestore_web - 2.8.10 3.12.5
collection - 1.18.0 1.18.0
fake_async - 1.3.1 1.3.1
firebase_core - 1.24.0 2.32.0
firebase_core_platform_interface - 4.8.0 5.0.0
firebase_core_web - 1.7.3 2.17.0
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
js - 0.6.7 0.7.1
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
lints - 1.0.1 4.0.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.1.6` on cloud_firestore does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

The constraint `^1.0.0` on flutter_lints does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_lints to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

388
likes
130
pub points
94%
popularity

Publisher

verified publishernoeatsleepteam.com

GeoFlutterFire is an open-source library that allows you to store and query firestore documents based on their geographic location.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cloud_firestore, flutter, flutter_lints, rxdart

More

Packages that depend on geoflutterfire