geodraw 0.1.0
geodraw: ^0.1.0 copied to clipboard

Flutter Android iOS

Draw geospatial information on a map. Marker, line and polygon pickers are available

3
likes
80 / 110
pub points
40 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 38 out of 39 API elements (97.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:geodraw/geodraw.dart that imports:
  • package:geodraw/src/pickers/polygon.dart that imports:
  • package:livemap/livemap.dart that imports:
  • package:livemap/src/position_stream.dart that imports:
  • package:geolocator/geolocator.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.25.0-8.1.pre..

lib/src/dialogs.dart:21:11

   ╷
21 │           FlatButton(
   │           ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/dialogs.dart

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.25.0-8.1.pre..

lib/src/dialogs.dart:27:11

   ╷
27 │           FlatButton(
   │           ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/dialogs.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cupertino_icons^0.1.20.1.31.0.2
flutterflutter0.0.00.0.0
geopoint^0.4.00.4.10.8.0
livemap^0.3.10.3.10.6.0
map_markers^0.1.00.1.00.1.0
pedantic^1.7.01.11.01.11.0
Transitive dependencies
PackageConstraintCompatibleLatest
ansicolor-1.1.11.1.1
async-2.5.02.5.0
cached_network_image-1.1.32.5.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
console_log_handler-1.1.61.1.6
convert-2.1.13.0.0
crypto-2.1.53.0.0
equatable-1.2.62.0.0
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_cache_manager-1.1.32.1.1
flutter_image-2.0.13.0.0
flutter_map-0.7.30.11.0
fluttertoast-3.1.37.1.8
geolocator-5.3.2+27.0.1
geopoint_location-0.3.00.4.0
google_api_availability-2.0.43.0.0
http-0.12.20.13.0
http_parser-3.1.44.0.0
intl-0.17.00.17.0
latlong-0.6.10.6.1
location_permissions-3.0.0+13.0.0+1
logging-0.11.41.0.0
map_controller-0.3.00.9.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider-1.6.272.0.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
positioned_tap_detector-1.0.31.0.3
process-4.1.04.1.0
quiver-2.1.53.0.0
rxdart-0.22.60.26.0
sky_engine-0.0.990.0.99
slugify2-0.2.10.2.1
source_span-1.8.11.8.1
speech_bubble-0.0.70.0.7
sqflite-1.3.2+42.0.0+2
sqflite_common-1.0.3+12.0.0+1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
transparent_image-1.0.01.0.0
tuple-1.0.31.0.3
typed_data-1.3.01.3.0
uuid-2.2.23.0.1
validate-1.7.01.7.0
vector_math-2.1.02.1.0
win32-2.0.02.0.0
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.1.2` on cupertino_icons does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions cupertino_icons to update the constraint.

The constraint `^0.4.0` on geopoint does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions geopoint to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Flutter 1.26.0-17.8.pre, Dart 2.12.0 (build 2.12.0-259.16.beta).

3
likes
80
pub points
40%
popularity

Draw geospatial information on a map. Marker, line and polygon pickers are available

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ansterj@gmail.com

License

MIT (LICENSE)

Dependencies

cupertino_icons, flutter, geopoint, livemap, map_markers, pedantic

More

Packages that depend on geodraw