geodesy 0.3.2
geodesy: ^0.3.2 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

A Dart library for geodesic and trigonometric calculations working with points and paths

16
likes
100 / 110
pub points
92 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 13 API elements (84.6 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/geodesy.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
latlong^0.6.10.6.10.6.1
pedantic^1.6.01.9.21.10.0
Transitive dependencies
PackageConstraintCompatibleLatest
ansicolor-1.1.11.1.1
console_log_handler-1.1.61.1.6
intl-0.16.10.17.0
logging-0.11.41.0.0
meta-1.2.41.3.0
path-1.7.01.8.0
validate-1.7.01.7.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

16
likes
100
pub points
92%
popularity

A Dart library for geodesic and trigonometric calculations working with points and paths

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

wingkwong.code@gmail.com

License

MIT (LICENSE)

Dependencies

latlong, pedantic

More

Packages that depend on geodesy