generic_api_generator 0.0.1
generic_api_generator: ^0.0.1 copied to clipboard

generic json api generator

0
likes
50 / 110
pub points
29 %
popularity

We analyzed this package on Apr 22, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 12 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:generic_api_generator/generic_api_generator.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/util/comment.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/source_io.dart that imports:
  • package:analyzer/src/generated/java_io.dart that imports:
  • dart:io
Pass static analysis
10 / 30

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

WARNING: Missing case clause for 'MapSerializable'.

lib/generic_api_generator.dart:417:11

    ╷
417 │           switch (clientAnnotation.parser) {
    │           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/generic_api_generator.dart

WARNING: Missing case clause for 'MapSerializable'.

lib/generic_api_generator.dart:462:13

    ╷
462 │             switch (clientAnnotation.parser) {
    │             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/generic_api_generator.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.30.39.171.5.0
build^1.2.21.6.22.0.1
built_collection^4.2.04.3.25.0.0
code_builder^3.2.03.7.04.0.0
dart_style^1.3.31.3.62.0.0
dio^3.0.13.0.104.0.0
retrofit^1.3.41.3.4+11.3.4+1
source_gen^0.9.4+20.9.10+21.0.0
tuple^1.0.21.0.32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.021.0.0
args-1.6.02.0.0
async-2.5.02.5.0
built_value-7.1.08.0.4
charcode-1.2.01.2.0
cli_util-0.2.00.3.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
file-5.2.16.1.0
fixnum-0.10.111.0.0
glob-1.2.02.0.1
html-0.14.0+40.15.0
http_parser-3.1.44.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
logging-1.0.11.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
node_interop-1.2.12.0.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pub_semver-1.4.42.0.0
quiver-2.1.53.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `^0.39.3` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.2.2` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.