galileo_mongo 3.0.0
galileo_mongo: ^3.0.0 copied to clipboard

MongoDB-enabled services for the Galileo framework. Well-tested.

0
likes
70/ 130
pub points
0%
popularity

We analyzed this package on Dec 1, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/galileo-dart/galileo_mongo was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 26 API elements (73.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:galileo_mongo/galileo_mongo.dart that imports:
  • package:galileo_mongo/services.dart that imports:
  • package:mongo_dart/mongo_dart.dart that imports:
  • package:mongo_dart/src/database/utils/dns_lookup.dart that imports:
  • package:basic_utils/basic_utils.dart that imports:
  • package:basic_utils/src/X509Utils.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/services.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
galileo_framework^3.0.23.0.24.0.0
galileo_json_god^3.0.13.0.13.0.1
galileo_merge_map^1.0.21.0.24.0.0
mongo_dart^0.7.0+10.7.40.7.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
basic_utils-3.9.13.9.1
boolean_selector-2.1.02.1.0
bson-1.0.41.0.4
buffer-1.1.11.1.1
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
essential_code_buffer-2.0.12.0.1
file-6.1.26.1.2
fixnum-1.0.01.0.0
galileo_combinator-1.1.14.0.3
galileo_container-2.2.24.0.4
galileo_http_exception-2.0.22.0.2
galileo_http_server-1.0.11.0.1
galileo_mock_request-1.0.84.0.0
galileo_model-2.0.04.0.0
galileo_route-5.0.16.0.1
http2-2.0.02.0.0
http_parser-4.0.04.0.0
js-0.6.30.6.3
json_annotation-4.4.04.4.0
logging-1.0.11.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
mime-1.0.11.0.1
mongo_dart_query-1.0.21.0.2
path-1.8.01.8.0
pointycastle-3.4.03.4.0
pool-1.5.01.5.0
quiver-3.0.1+13.0.1+1
rational-1.2.12.0.0
recase-4.0.04.0.0
sasl_scram-0.1.00.1.0
saslprep-1.0.21.0.2
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.4.80.4.8
tuple-2.0.02.0.0
typed_data-1.3.01.3.0
unorm_dart-0.2.00.2.0
uuid-3.0.53.0.5
vy_string_utils-0.4.30.4.3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.2` on galileo_framework does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions galileo_framework to update the constraint.

The constraint `^1.0.2` on galileo_merge_map does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions galileo_merge_map to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
70
pub points
0%
popularity

Publisher

galileodart.com

MongoDB-enabled services for the Galileo framework. Well-tested.

Repository (missing)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

galileo_framework, galileo_json_god, galileo_merge_map, mongo_dart

More

Packages that depend on galileo_mongo