galileo_mongo 3.0.0 icon indicating copy to clipboard operation
galileo_mongo: ^3.0.0 copied to clipboard

MongoDB-enabled services for the Galileo framework. Well-tested.

example/example.dart

import 'package:galileo_framework/galileo_framework.dart';
import 'package:galileo_mongo/galileo_mongo.dart';
import 'package:mongo_dart/mongo_dart.dart';

main() async {
  var app = new Galileo();
  Db db = new Db('mongodb://localhost:27017/local');
  await db.open();

  var service = app.use('/api/users', new MongoService(db.collection("users")));

  service.afterCreated.listen((event) {
    print("New user: ${event.result}");
  });
}
0
likes
80
pub points
0%
popularity

Publisher

shield icon for verified publishersgalileodart.com

MongoDB-enabled services for the Galileo framework. Well-tested.

Repository (missing)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

galileo_framework, galileo_json_god, galileo_merge_map, mongo_dart

More

Packages that depend on galileo_mongo