front_matter 1.1.0 icon indicating copy to clipboard operation
front_matter: ^1.1.0 copied to clipboard

A front matter parser that extracts YAML metadata from the start of a file or string.

2
likes
100/ 130
pub points
63%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 14 out of 17 API elements (82.4 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:front_matter/front_matter.dart that imports:
  • package:front_matter/src/front_matter.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
yaml^2.1.152.2.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.16.01.16.0
path-1.8.21.8.2
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.15` on yaml does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions yaml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.13, Dart 2.17.5.

2
likes
100
pub points
63%
popularity

Publisher

unverified uploader

A front matter parser that extracts YAML metadata from the start of a file or string.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

yaml

More

Packages that depend on front_matter